VBM8-Toolbox Manual

INTRODUCTION AND OVERVIEW 2

GETTING STARTED 3
  Download and Installation 3
  Starting the Toolbox 3
  Basic VBM analysis (overview) 4

BASIC VBM ANALYSIS (DETAILED DESCRIPTION) 6
  Modules 6
    First Module: Estimate and write 6
    Second Module: Display one slice for all images 8
    Third Module: Check sample homogeneity using covariance 8
    Fourth Module: Smooth 9
  Building the statistical model 10
    Two-sample T-Test 11
    Using the Full Factorial Model (for a 2x2 Anova) 12
    Multiple Regression (Correlation) 13
    Using the Full Factorial Model (for an Interaction) 14
    Estimating the statistical model 15
    Defining Contrasts 15

SPECIAL CASES 17
  VBM8 for longitudinal data 17
    Change Settings for Preprocessing 18
    Preprocessing of longitudinal data 18
    Statistical Analysis of longitudinal data in one group 19
    Statistical Analysis of longitudinal data in two groups 20
  Altered Workflows for VBM-analyses 23
  Adapting the workflows 24
    Customized Tissue Probability Maps 24
    Customized DARTEL-template 25

ADDITIONAL INFORMATION ON NATIVE, NORMALIZED AND MODULATED VOLUMES 27

NAMING CONVENTION OF OUTPUT FILES 28

TECHNICAL INFORMATION 29

REFERENCES 30
Introduction and Overview

This manual is intended to help any user to perform a VBM analysis using the VBM8 Toolbox. It covers different aspects of this type of analysis – starting with the very basics and ending up with additional information on how to deal with different data. Basically it may be divided into four main sections:

• Naturally, a quick guide of how to get started is given at the beginning. This section provides information how to download and install the software and start the Toolbox. Furthermore, a short overview on the steps of a VBM analysis is given.

• A detailed description of a basic VBM analysis is subsequently given, which will guide the user step by step through the whole process – from preprocessing to the selection of contrasts. This description should provide all necessary information to analyze most studies successfully.

• There are a few special cases of VBM analyses, for which the basic analysis workflow has to be adapted. These cases are longitudinal studies and studies in children or special patient populations. Relevant changes to a basic VBM analysis are described here and a description of how to apply these changes is provided. Importantly, only the changes are described – steps like for example quality control or smoothing are the same as in the basic analysis and not described a second time.

• The manual closes with information on native, normalized and modulated volumes, which determines how the results may be interpreted. Furthermore an overview of the naming conventions used as well as technical information is given.
Getting Started

DOWNLOAD AND INSTALLATION

- The VBM8 Toolbox runs within SPM8. That is, SPM8 needs to be installed and added to your Matlab search path before the VBM8 Toolbox can be installed (see http://www.fil.ion.ucl.ac.uk/spm/ and http://en.wikibooks.org/wiki/SPM).

- Download (http://dbm.neuro.uni-jena.de/vbm8/) and unzip the VBM8 Toolbox. You will get a folder named “vbm8”, which contains various matlab files and compiled scripts. Copy the folder “vbm8” into the SPM8 “toolbox” folder.

STARTING THE TOOLBOX

- Start Matlab
- Start SPM8 (i.e., type “spm fmri”)
- Select “vbm8” from the SPM menu (see Figure 1). You will find the drop-down menu between the “Display” and the “Help” button. This will open the VBM8 Toolbox (in SPM’s 2nd window). You can access the VBM8 Toolbox menu by clicking on “VBM8” (located at the upper left corner of this window; see Figure 2).

![Figure 1: SPM menu](image1.png)

![Figure 2: SPM’s 2nd window with the VBM8 Toolbox menu](image2.png)
BASIC VBM ANALYSIS (OVERVIEW)
The VBM8 Toolbox comes with different modules, which may be used for an analysis. Usually, a VBM analysis comprises the following steps:

(a) Preprocessing:
1. T1 images are normalized to a template space and segmented into gray matter (GM), white matter (WM) and cerebrospinal fluid (CSF). The preprocessing parameters can be adjusted via the module “Estimate and write”.
2. After the preprocessing is finished, a quality check is highly recommended. This can be achieved via the modules “Display one slice for all images” and “Check sample homogeneity using covariance”. Both options are located under “VBM8 → Check data quality”.
3. Before entering the GM images into a statistical model, image data need to be smoothed. Of note, this step is not implemented into the VBM8 Toolbox but achieved via the standard SPM module “Smooth”.

(b) Statistical analysis:
4. The smoothed GM images are entered into a statistical analysis. This requires building a statistical model (e.g., T-Tests, ANOVAs, multiple regressions). This is done by the standard SPM modules “Specify 2nd Level”.
5. The statistical model is estimated. This is done by the standard SPM module “Estimate”.
6. After estimating the statistical model, contrasts will be defined to get the results of the analysis. This is done by the standard SPM module “Results”.

The sequence of “preprocessing → quality check → smoothing → statistical analysis” remains the same for every VBM analysis, even when different steps are adapted (see “special cases”).
A few words about the Batch Editor...

- As soon as you select a module from the VBM8 Toolbox menu, a new window (the Batch Editor) will open. The Batch Editor is the environment where you will set up your analysis (see Figure 3). For example, an “<X” indicates where you need to select files (e.g., your image files, the template, etc.). Other parameters have either default settings (which can be modified) or require input (e.g., choosing between different options, providing text or numeric values, etc.).

- Once all missing parameters are set, a green arrow will appear on the top of the window (the current snapshots in Figure 3 show the arrow still in gray). Click this arrow to run the module or select “File → Run Batch”. It is very useful to save the settings before you run the batch (click on the disk symbol or select “File → Save Batch”).

- Of note, you can always find helpful information and parameter-specific explanations at the bottom of the Batch Editor window.¹

- All settings can be saved either as .mat file or as .m script file and reloaded for later use. The .m script file has the advantage to be editable with a text editor.

![Figure 3: The Batch Editor is the environment where the analysis is set up. Left: For all settings marked with “<X”, files have to be selected (“Select Files”). Right: Parameters can be edited and adapted (“Edit Value”).](image)

¹ Additional VBM8-related information can be found by selecting “VBM Tools website” in the VBM8 Toolbox menu. This will open a website. Here, look for “VBM subpages” on the right.

Of note, for debugging, the relevant information can be printed by selecting “Print VBM debug information” from the VBM8 Toolbox menu.
**Basic VBM analysis (detailed description)**

1. Select your working directory.
   
   Before running anything, it is recommended to always set SPM’s working directory: “Utilities → CD” (right to the “Help” button in the SPM main menu). Select your working directory and click “Done” to change the directory.

2. Open the VBM Toolbox.

3. Select the module you want to run.

4. Specify the parameters (see below).

5. Run the module.

**Modules**

**FIRST MODULE: ESTIMATE AND WRITE**

VBM8 → Estimate and write

Parameters:

- Volumes <X → Select Files → [select raw data] → Done
  
  - Select one volume for each subject. As the Toolbox does not support multispectral data yet (i.e., different imaging methods for the same brain, such as T1-, T2-, diffusion-weighted or CT images), it is recommended to choose a T1-weighted image.

  - Importantly, the images need to be in the same orientation as the template and priors; you can double-check and correct via using “Display” in the SPM menu. By default the MNI template is used (located in your SPM folder “spm8 → templates → T1”)

- Estimation Options → [use defaults or modify]
  
  - The defaults provide a solid starting point for the analysis. If you prefer to use your own customized Tissue Probability Maps (TPMs), you can specify / select them here. However, the new segmentation approach in VBM8 does not need tissue priors for the segmentation anymore. Customized TPMs will be only used for the spatial normalization. Thus, creating your own TPMs might be only appropriate for children’s data if they largely deviate from the
standard MNI template. In order to create your own TPMs the Template-O-Matic (TOM8) Toolbox can be used.

- **Extended Options → [use defaults or modify]**
  - Again, the defaults provide a solid starting point. The high-dimensional DARTEL normalization is used as the default spatial normalization. Alternatively, the low-dimensional SPM8 spatial normalization can be chosen. Furthermore, remaining non-brain tissue can be removed more thoroughly by setting the option “Clean up any partitions” to “Thorough Cleanup”. This is particularly useful for very atrophic brains (e.g., as occurring in Alzheimer’s disease). The parameters for two de-nosing methods can be also changed. The optimal weighting for the SANLM filter is internally estimated. The MRF weighting is not necessary to change, because the SANLM filter will have a much larger de-nosing effect. Values of “0” will deselect both filters.

- **Writing Options → [use defaults or modify]**
  - **For GM, WM, and CSF image volumes** see page 14: “Additional Information on native, normalized and modulated normalized volumes”. Note: The default option “Modulated normalized – non linear only” will result in an analysis of relative differences in regional GM volume, corrected for individual brain size.
  - **A bias corrected image volume**, in which MRI inhomogeneities and noise are removed, can be written in normalized or native space. This is useful for quality control and also to create an average image of all normalized T1 images in order to display / overlay the results. Note: For a basic VBM analysis use the defaults.
  - **A partial volume effect (PVE) label image volume** can also be written in normalized or native space or as a DARTEL export file. This is useful for quality control and also for future applications using this image to reconstruct surfaces. Note: For a basic VBM analysis use the defaults.
  - The **Jacobian determinant** for each voxel can be written in normalized space. This information can be used to do a Tensor-Based Morphometry (TBM) analysis. Note: For a basic VBM analysis this is not needed.
  - **Finally, deformation fields** can be written. This option is useful to re-apply normalization parameters to other images or particular regions of interest. Note: For a basic VBM analysis this is not needed.

After setting all parameters, you will be able to save and run the module:

- **File → Save Batch** [optionally save your model and selections as a *.m script file; the next time you can simply load this *.m script file with “Load Batch”, and adjust / modify respective sections if necessary].

- **File → Run Batch** [the outcomes will be written to the same directory like the original data]. As per defaults, the outcomes will be the bias corrected normalized volumes (wm*) and the tissue segments (i.e., the modulated normalized gray matter (m0wp1*) and white matter (m0wp2*) segments of each volume). If you selected the low-dimensional spatial normalization approach the modulated images will be named m0wp1* for gray matter and m0wp2* for white matter. All
possible naming is summarized under “Naming convention of output files” (p. 17) and in the graphics window of SPM, when the SPM8 Toolbox is started.

SECOND MODULE: DISPLAY ONE SLICE FOR ALL IMAGES

VBM8 → Check data quality → Display one slice for all images

Parameters:

- Volumes <X → Select Files → [select the new files] → Done
  - Select the newly written data [e.g. the “wm*” files, which are the normalized bias corrected volumes]. This tool will display one horizontal slice for each subject, thus giving a good overview if the segmentation and normalization procedures yielded reasonable results. For example, if the native volume had artifacts or if the native volumes had a wrong orientation, the results may look odd. Solutions: Use “Check Reg” from the SPM main menu to make sure that the native images have the same orientation like the MNI Template (“SPM → templates → T1”). Adjust if necessary using “Display” from the SPM main menu.

- Proportional scaling → [use defaults or modify]
  - Check “yes”, if you display T1 volumes.

Show slice in mm → [use defaults or modify]

- This module displays horizontal slices. This default setting provides a good overview.

- File → Save Batch
- File → Run Batch [the outcomes will be displayed in SPM’s graphic window]

THIRD MODULE: CHECK SAMPLE HOMOGENEITY USING COVARIANCE

VBM8 → Check data quality → Check sample homogeneity using covariance

Parameters:

- Volumes <X → Select Files → [select gray matter volumes] → Done
  - Select the newly written data [e.g. the “m0wrp1*” files, which are the normalized (wr) GM segments (p1) modulated for the non-linear components (m0)]. This tool visualizes the covariance between the volumes using a boxplot and covariance matrices. Thus, it will help identifying outliers. Any outlier should be carefully
inspected for artifacts or pre-processing errors using “Check Reg” from the SPM main menu.

- Proportional scaling → [use defaults or modify]
  - Check “yes”, if you display T1 volumes.

- Show slice in mm → [use defaults or modify]
  - “0mm” means the center slice along the origin of the MNI template.

- Nuisance → [enter nuisance variables if applicable]
  - For each nuisance variable which you want to remove from the data prior to calculating the covariance, select “New: Nuisance” and enter a vector with the respective variable for each subject (e.g. age in years). All variables have to be entered in the same order as the respective volumes. You can also type “spm_load” to upload a *txt file with the covariates in the same order as the volumes.

- File → Save Batch

- File → Run Batch
  - A boxplot window and covariance matrices will open, which depict the covariance between the volumes; outliers can be displayed in SPM’s graphic window. The covariance matrix shows the covariance between all volumes. High covariance values mean that your data are more similar. The boxplot summarizes all covariance values for each subject and shows the homogeneity of your sample. A small overall covariance in the boxplot not always means that this volume is an outlier or contains an artifact. If there are no artifacts in the image and if the image quality is reasonable you don’t have to exclude this volume from the sample. This tool is intended to utilize the process of quality checking and there is no clear criteria defined to exclude a volume only based on the overall covariance value. However, volumes with an overall covariance below two standard deviations are indicated and should be checked very carefully.

---

FOURTH MODULE: SMOOTH

SPM menu → Smooth

Parameters:

- Images to Smooth <-X → Select Files → [select grey matter volumes] → Done
- Select the newly written data [e.g. the “m0wrp1” files, which are the normalized (wr) grey matter segments (p1) modulated for the non-linear components (m0)].
  - FWHM → [use defaults or modify]
  - 8-12mm kernels are widely used for VBM. To use this setting select “edit value” and type “8 8 8” (or “12 12 12”, respectively) for a kernel with 8mm (with 12mm) FWHM.
  - Data Type → [use defaults or modify]
  - Filename Prefix → [use defaults or modify]

- File → Save Batch [this will save the parameters as *.m script file]
- File → Run Batch [the outcomes will be written to the same directory like the original data]

**Building the statistical model**

Although there are many potential designs offered in the 2nd-level analysis I recommend to use the “Full factorial” design because it covers most statistical designs. For cross-sectional VBM data you have usually 1..n samples and optionally covariates and nuisance parameters:

<table>
<thead>
<tr>
<th>Number of factor levels</th>
<th>Number of covariates</th>
<th>Statistical Model</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>0</td>
<td>one-sample t-test</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
<td>single regression</td>
</tr>
<tr>
<td>1</td>
<td>&gt;1</td>
<td>multiple regression</td>
</tr>
<tr>
<td>2</td>
<td>0</td>
<td>two-sample t-test</td>
</tr>
<tr>
<td>&gt;2</td>
<td>0</td>
<td>Anova</td>
</tr>
<tr>
<td>&gt;1</td>
<td>&gt;0</td>
<td>Ancova (for nuisance parameters)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or Interaction (for covariates)</td>
</tr>
</tbody>
</table>
TWO-SAMPLE T-TEST

SPM menu → Specify 2nd-level

Parameters:

- Directory <-X → Select Files [select the working directory for your analysis] → Done
- Design → “Two-sample t-test”
  - Group 1 scans → Select Files [select the smoothed grey matter volumes for group 1; following this script these will be the “sm0wp1” files] → Done
  - Group 2 scans → Select Files [select the smoothed grey matter volumes for group 2] → Done
  - Independence → Yes
  - Variance → Equal or Unequal
  - Grand mean scaling → No
  - ANCOVA → No
- Covariates*
- Masking
  - Threshold Masking → Absolute → [specify value (e.g., “0.1”)]
  - Implicit Mask → Yes
  - Explicit Mask → <None>
- Global Calculation → Omit
- Global Normalization
  - Overall grand mean scaling → No
- Normalization → None

You could specify one or many covariates (i.e., partial out the variance of specific factors when looking at group differences)

- Covariates → New Covariate
- Vector <-X → enter the values of the covariates (e.g., age in years) in the same order as the respective file names or type “spm_load” to upload a *.txt file with the covariates in the same order as the volumes
- Name <-X → Specify Text (e.g., “age”)
- Interactions → None
- Centering → No centering

File → Save Batch [this will save the parameters as *.m script file]
File → Run Batch [this will create an “SPM.mat” file in your working directory]
USING THE FULL FACTORIAL MODEL (FOR A 2X2 ANOVA)

SPM menu → Specify 2nd-level

Parameters:
  - Directory <X → Select Files → [select the working directory for your analysis] → Done
  - Design → “Full Factorial”
    - Factors → “New: Factor; New: Factor”
      - Name → [specify text (e.g., “sex”)]
      - Levels → 2
      - Independence → Yes
      - Variance → Equal or Unequal
      - Grand mean scaling → No
      - ANCOVA → No
      - Factor
      - Name → [specify text (e.g., “handedness”)]
      - Levels → 2
      - Independence → Yes
      - Variance → Equal or Unequal
      - Grand mean scaling → No
      - ANCOVA → No
    - Specify Cells → “New: Cell; New: Cell; New: Cell; New: Cell”
      - Cell
      - Levels → [specify text (e.g., “1 1”)]
      - Scans → [select files (e.g., the smoothed GM volumes of the left-handed males)]
      - Cell
      - Levels → [specify text (e.g., “1 2”)]
      - Scans → [select files (e.g., the smoothed GM volumes of the right-handed males)]
      - Cell
      - Levels → [specify text (e.g., “2 1”)]
      - Scans → [select files (e.g., the smoothed GM volumes of the left-handed females)]
      - Cell
      - Levels → [specify text (e.g., “2 2”)]
      - Scans → [select files e.g., the smoothed GM volumes of the right-handed females]
  - Covariates*
  - Masking
    - Threshold Masking → Absolute → [specify value (e.g., “0.1”)]
MULTIPLE REGRESSION (CORRELATION)

SPM menu → Specify 2nd-level

Parameters:

- Directory <X → Select Files → [select the directory for your analysis] → Done
- Design → “Multiple Regression”
  - Scans → [select files (e.g., the smoothed GM volumes of all subjects)] → Done
  - Covariates → “New: Covariate”
    - Covariate
      - Vector → [enter the values in the same order as the respective file names of the smoothed GM images]
      - Name → [specify test (e.g., “age”)]
      - Centering → No centering
      - Intercept → Include Intercept
- Covariates*
- Masking
  - Threshold Masking → Absolute → [specify value (e.g., “0.1”)]
  - Implicit Mask → Yes
  - Explicit Mask → <None>
- Global Calculation → Omit
- Global Normalization
  - Overall grand mean scaling → No
- Normalization → None

- File → Save Batch [this will save the parameters as *.m script file]
- File → Run Batch [This will create an “SPM.mat” file in your selected folder]
USING THE FULL FACTORIAL MODEL (FOR AN INTERACTION)

SPM menu → Specify 2nd-level

Parameters:

- Directory <-> X → Select Files → [select the working directory for your analysis] → Done
- Design → “Full Factorial”
  - Factors → “New: Factor”
    - Factor
      - Name → [specify text (e.g., “sex”)]
      - Levels → 2
      - Independence → Yes
      - Variance → Equal or Unequal
      - Grand mean scaling → No
      - ANCOVA → No
  - Specify Cells → “New: Cell; New: Cell”
    - Cell
      - Levels → [specify text (e.g., “1”)]
      - Scans → [select files (e.g., the smoothed GM volumes of the males)]
    - Cell
      - Levels → [specify text (e.g., “2”)]
      - Scans → [select files (e.g., the smoothed GM volumes of the females)]
- Covariates → “New: Covariate”
  - Covariate
    - Vector → [enter the values in the same order as the respective file names of the smoothed GM images]
    - Name → [specify test (e.g., “age”)]
    - Interactions → With Factor 1
    - Centering → No centering
- Masking
  - Threshold Masking → Absolute → [specify value (e.g., “0.1”)]
  - Implicit Mask → Yes
  - Explicit Mask → <None>
- Global Calculation → Omit
- Global Normalization
  - Overall grand mean scaling → No
- Normalization → None

- File → Save Batch [this will save the parameters as *.m script file]
- File → Run Batch [this will create an “SPM.mat” file in your working directory]
ESTIMATING THE STATISTICAL MODEL

SPM menu → Estimate

Parameters:
- Select SPM.mat <-X → Select Files → [select the SPM.mat which you just built] → Done
- Method → “Classical”

- File → Save Batch
- File → Run Batch [This will create an “SPM.mat” file in your selected folder]

DEFINING CONTRASTS

SPM menu → Results → [select the SPM.mat file] → Done (this opens the Contrast Manager) → Define new contrast (i.e., choose “t-contrast” or “F-contrast”; type the contrast name and specify the contrast by typing the respective numbers, as shown below):

T-contrasts:

a. Simple group difference
   → Use SPM.mat from model “2 sample T-test”
      • For Group A > Group B: specify “1 -1”
      • For Group A < Group B: specify “-1 1”

b. 2x2 ANOVA
   → Use SPM.mat from model “2x2 ANOVA”
      • For left-handed males > right-handed males: specify “1 -1 0 0”
      • For left-handed females > right-handed females: specify “0 0 1 -1”
      • For left-handed males > left-handed females: specify “1 0 -1 0”
      • For right-handed males > right-handed females: specify “0 1 0 -1”
      • For males > females: specify “1 1 -1 -1”
      • For left-handers > right-handers: specify “1 -1 1 -1”

etc.
c. Multiple Regression (Correlation)
   ⇒ Use SPM.mat from model “CORRELATION”
   • For positive correlation: specify “1”
   • For negative correlation: specify “-1”

d. Interaction
   ⇒ Use SPM.mat from model “INTERACTION”
   • For regression slope Group A > Group B: specify “0 0 1 -1”
   • For regression slope Group A < Group B: specify “0 0 -1 1”

→ Done

F-contrasts:
If you would like to use the old SPM2 F-contrast “Effects of interest” the respective contrast vector is:

\[
\text{eye}(n) - \frac{1}{n}
\]

where \( n \) is the number of columns of interest. This F-contrast is often helpful for plotting parameter estimates of effects of interest.

Getting Results:
SPM menu → Results → [select a contrast from Contrast Manager] → Done

• Mask with other contrasts → No
• Title for comparison: [use the pre-defined name from the Contrast Manager or change it]
• P value adjustment to:
  o None (uncorrected for multiple comparisons), set threshold to 0.001
  o FDR (false discovery rate), set threshold to 0.05, etc.
  o FWE (family-wise error), set threshold to 0.05, etc.
• Extent threshold: [either use “none” or specify the number of voxels²]

---

² In order to \textit{empirically} determine the extent threshold (rather than saying 100 voxels or 500 voxels, which is completely arbitrary), simply run this first without specifying an extent threshold. This will give you an output (i.e., the standard SPM glass brain with significant effects). When you click “Table” (SPM main menu) you will get a table with all relevant values (MNI coordinates, p-values, cluster size etc). Below the table you will find additional information, such as “Expected Number of Voxels per Cluster”. Remember this number (this is your empirically determined extent threshold). Re-run SPM → Results etc. and specify this number when asked for the “Extent Threshold”. There is also a hidden option in “VBM8 → Data presentation → Threshold and transform spmT-maps” to define the extent threshold in terms of a p-value or to use the “Expected Number of Voxels per Cluster”.

16
**Special Cases**

**VBM8 for longitudinal data**

**BACKGROUND**
The majority of VBM studies are based on cross-sectional data, where one image is acquired for each subject. However, in order to track e.g. learning effects over time longitudinal designs are necessary, where additional time-points are acquired for each subject. The analysis of these longitudinal data requires a customized processing, that considers the characteristics of intra-subject analysis. While for cross-sectional data images can be processed independently for each subject longitudinal data has to be registered to the baseline image (or mean image) for each subject. Furthermore, spatial normalization is estimated for the baseline image only and applied to all images (Figure 4). Additional attention is then needed for the setup of the statistical model. The following section will therefore describe data preprocessing and model setup for longitudinal data.

![Flow diagram for processing longitudinal data with VBM8](image)

*Fig 4.: Flow diagram for processing longitudinal data with VBM8. This figure demonstrates the steps for processing longitudinal data. After an initial realignment, the mean of the realigned images is calculated (mean) and used as reference image in a subsequent realignment. The realigned images (ri,) are then corrected for signal inhomogeneities with regard to the reference mean image. Spatial normalization parameters are estimated in the next step using the segmentations of the mean image. These normalization parameters are applied to the segmentations of the bias-corrected images (p1mri,). The resulting normalized segmentations (wp1mri,) are finally again realigned.*
Preprocessing of longitudinal data - overview
The VBM8 Toolbox supplies a batch for longitudinal study design. Here, for each subject the respective images need to be selected. Intra-subject realignment, bias correction, segmentation, and normalization are calculated automatically. Preprocessed images are written as wp1mr* and wp2mr* for grey and white matter respectively. To define the segmentation and normalization parameters, the defaults in cg_vbm8_defaults.m are used.

CHANGE SETTINGS FOR PREPROCESSING

Change your working directory to “/toolbox/vbm8” in your SPM directory:
→ select “Utilities → cd” in the SPM menu and change to the respective folder.
Then type “open cg_vbm8_defaults.m” in your matlab command window. The file will open in the editor. If you are unsure how to change the values, open the module “estimate and write” in the batch editor for reference.

The most interesting parameters to change here may be:
• DARTEL or spm8 default normalization:
  Line 65 → set to “0” for spm8 default normalization

• The Tissue Probability Maps:
  Line 16 → replace “(fullfile(spm('dir'),'toolbox','Seg','TPM.nii'))” with the path to your Maps.

It is always a great idea to memorize or record the changes and change all values back to default after the Analysis.

PREPROCESSING OF LONGITUDINAL DATA

VBM8 → Process longitudinal data
Parameters:
  o Data <-X → New: Subject → Subject → Longitudinal data for one subject → Select Files → [select raw data] → Done
    - Select all volumes for each subject. As the Toolbox does not support multispectral data yet (i.e., different imaging methods for the same brain, such as T1-, T2-, diffusion-weighted or CT images), it is recommended to choose a T1-weighted image.
    - Select “New: Subject” to add data for a new subject
      The data for each subject should be listed as one “subject” in the Batch Editor, i.e. there are as many subjects listed as included in the analysis.
- File → Save Batch [this will save the parameters as *.m script file]
- File → Run Batch [this will create an “SPM.mat” file in your working directory]

For the naming conventions of all written files see p.29 “Naming convention of output files”. The final GM segments are wp1mr*, the final WM segments are named wp2mr*.

**Statistical analysis of longitudinal data - overview**

The main interest in longitudinal studies is the common change of tissue volume over time in a group of subjects or the difference in these changes between two or more groups. The setup of the statistical model needed to assess these questions will be described on two examples. First, the case of only one group of 4 subjects with 2 time points each (e.g. normal aging) is presented. Subsequently, the case of two groups of subjects with 4 time points per subject will be described. These examples should cover most analyses – the number of time points / groups just have to be adapted.

**STATISTICAL ANALYSIS OF LONGITUDINAL DATA IN ONE GROUP**

SPM menu → Specify 2nd-level

Parameters:

- Directory <-X → Select Files → [select the working directory for your analysis] → Done
- Design → “Flexible Factorial”
  - Factors → “New: Factor; New: Factor”
    - Factor
      - Name → [specify text (e.g., “subject”)]
      - Independence → Yes
      - Variance → Equal or Unequal
      - Grand mean scaling → No
      - ANCOVA → No
    - Factor
      - Name → [specify text (e.g., “time”)]
      - Independence → No
      - Variance → Equal or Unequal
      - Grand mean scaling → No
      - ANCOVA → No
  - Specify Subjects or all Scans & Factors → “Subjects” → “New: Subject; New: Subject; New: Subject;”
    - Subject
      - Scans → [select files (the smoothed GM volumes of the first Subject)]
      - Conditions → “1 2” [for two time points]
    - Subject
      - Scans → [select files (the smoothed GM volumes of the second Subject)]
- Conditions → “1 2” [for two time points]
  Subject
- Scans → [select files (the smoothed GM volumes of the third Subject)]
- Conditions → “1 2” [for two time points]
  Subject
- Scans → [select files (the smoothed GM volumes of the fourth Subject)]
- Conditions → “1 2” [for two time points]

- Main effects & Interaction → “New: Main effect”
  Main effect
  - Factor number → 2
  Main effect
  - Factor number → 1

- Covariates (see “basic VBM analysis (detailed description)“)

- Masking
  - Threshold Masking → Absolute → [specify value (e.g., “0.1”)]
  - Implicit Mask → Yes
  - Explicit Mask → <None>

- Global Calculation → Omit

- Global Normalization
  - Overall grand mean scaling → No

- Normalization → None

- File → Save Batch [this will save the parameters as *.m script file]
- File → Run Batch [this will create an “SPM.mat” file in your working directory]

STATISTICAL ANALYSIS OF LONGITUDINAL DATA IN TWO GROUPS

SPM menu → Specify 2nd-level

Parameters:

- Directory <-X → Select Files → [select the working directory for your analysis] → Done

- Design → “Flexible Factorial”

    Factor
    - Name → [specify text (e.g., “subject”)]
    - Independence → Yes
    - Variance → Equal
    - Grand mean scaling → No
- ANCOVA → No
Factor
- Name → [specify text (e.g., “group”)]
- Independence → Yes
- Variance → Unequal
- Grand mean scaling → No
- ANCOVA → No
Factor
- Name → [specify text (e.g., “time”)]
- Independence → No
- Variance → Equal
- Grand mean scaling → No
- ANCOVA → No

- Specify Subjects or all Scans & Factors → “Subjects” → “New: Subject; New: Subject; New: Subject;”
  Subject
  - Scans → [select files (the smoothed GM volumes of the 1st Subject of first group)]
  - Conditions → “[1 1 1 1; 1 2 3 4]” “[first group with four time points]”

  Do not forget the additional single quote!
Subject
  - Scans → [select files (the smoothed GM volumes of the 2nd Subject of first group)]
  - Conditions → “[1 1 1 1; 1 2 3 4]” “[first group with four time points]”
Subject
  - Scans → [select files (the smoothed GM volumes of the 3rd Subject of first group)]
  - Conditions → “[1 1 1 1; 1 2 3 4]” “[first group with four time points]”
Subject
  - Scans → [select files (the smoothed GM volumes of the 4th Subject of second group)]
  - Conditions → “[2 2 2 2; 1 2 3 4]” “[second group with four time points]”
Subject
  - Scans → [select files (the smoothed GM volumes of the 1st Subject of second group)]
  - Conditions → “[2 2 2 2; 1 2 3 4]” “[second group with four time points]”
Subject
  - Scans → [select files (the smoothed GM volumes of the 2nd Subject of second group)]
  - Conditions → “[2 2 2 2; 1 2 3 4]” “[second group with four time points]”
Subject
  - Scans → [select files (the smoothed GM volumes of the 3rd Subject of second group)]
  - Conditions → “[2 2 2 2; 1 2 3 4]” “[second group with four time points]”
Subject
- Scans → [select files (the smoothed GM volumes of the 4th Subject of second group)]
- Conditions → “[2 2 2 2; 1 2 3 4]” [second group with four time points]
  ▪ Main effects & Interaction → “New: Interaction; New: Main effect”
    Interaction
  - Factor numbers → 2 3 [Interaction between group and time]
  - Factor number → 1
  o Covariates (see “basic VBM analysis (detailed description)”)
  o Masking
    ▪ Threshold Masking → Absolute → [specify value (e.g., “0.1”)]
    ▪ Implicit Mask → Yes
    ▪ Explicit Mask → <None>
  o Global Calculation → Omit
  o Global Normalization
    ▪ Overall grand mean scaling → No
  o Normalization → None
- File → Save Batch [this will save the parameters as *.m script file]
- File → Run Batch [this will create an “SPM.mat” file in your working directory]


**Altered Workflows for VBM-analyses**

**Background**
For most analyses the VBM Toolbox will supply all tools needed. That is, as the new segmentation algorithm is not dependent on Tissue Probability Maps (TPMs) anymore and as predefined DARTEL-templates for healthy adults exist, most questions can be assessed using the toolbox settings. However, for some special cases such as analyses in children or special patient populations, the toolbox settings might not be optimal. For these cases the VBM8 Toolbox provides an integration into the SPM8 environment that can be used to optimize the preprocessing. In the following, we will present strategies how to deal with these special cases.

**Standard VBM preprocessing: Input, Output and where to modify**
The first module of the VBM8 Toolbox (“Estimate and Write”) processes all preprocessing steps except for the smoothing. Basically, it takes structural volumes and TPMs as input. It will then segment the data, apply a registration to MNI Space (either rigid or affine) and subsequently a non-linear deformation. The non-linear deformation parameters can be calculated via the low dimensional SPM default approach or the high dimensional DARTEL algorithm and the predefined templates. Figure 5 depicts this preprocessing workflow and highlights possibilities where to modify.

*Fig. 5: Flow-chart of the preprocessing steps within the module “Estimate and Write”. Marked in red are those steps, where the preprocessing can be customized. Per default, the built-in DARTEL normalization works with the VBM8 DARTEL templates of 550 healthy adult control subjects. Affine registered tissue segments can be used to create customized DARTEL-templates, which can then be used to replace the default DARTEL template.*
Adapting the workflows

Customized Tissue Probability Maps - overview
For data on children it will be a good idea to create customized TPMs, which reflect age and gender of the population. The TOM8 Toolbox (available via: https://irc.cchmc.org/software/tom.php) provides the means to customize these TPMs. To learn more about the TOM toolbox, see also http://dbm.neuro.uni-jena.de/software/tom/.

CUSTOMIZED TISSUE PROBABILITY MAPS

About the TOM8 Toolbox:
→ select Module “create new template”
   → select “TOM.mat” (you will have to download this file together with the toolbox)
   → write priors/template as single file
   → for all others use default settings or modify. For “Age” either a vector or a mean age (when using the average approach) must be specified.

Implementation into VBM8:
Module: “Estimate and write”
→ “Estimation Options”.
   → Tissue Probability Maps (→ Select your customized TPMs here)

Customized DARTEL-template - overview
For all cases that include at least 50-100 subjects a customized DARTEL template can be created. That is, grey matter and white matter tissue segments of all subjects are used to create a mean template of the study sample. As the VBM8 toolbox writes all files needed to create these templates (“DARTEL export”), this requires only two additional steps. In order to use these newly created DARTEL-Template with the vbm8 Toolbox, an affine registration of the DARTEL export should be used. From these affine registered segments customized DARTEL templates can then be created and used with the vbm8 module “Write already estimated segmentations”.

24
Three steps are needed to create normalized tissue segments with customized DARTEL Templates. These steps can be batched using dependencies in the Batch Editor. The last step can be rerun using the customized templates, if additional output files are needed. In the first step the T1 images are segmented, and the tissue segments normalized to the Tissue Probability Maps using an affine transformation. Start with selecting the module “Estimate and Write”.

Module: “Estimate and Write”:

- for all options except “writing options” use settings like for a “standard” VBM analysis.
- “Writing Options”
  - “Grey Matter” → “DARTEL export” → “affine”
  - “White Matter” → “DARTEL export” → “affine”

These settings will produce the volumes “rp1*-affine.nii” and “rp2*-affine.nii”, which are the grey (rp1) and white (rp2) matter segments after affine registration. The following modules can be chosen directly in the batch editor (SPM → Tools → DARTEL Tools → Run DARTEL (create Templates), and SPM → Tools → VBM8 → VBM8: Write already estimated segmentations). It makes sense to add and specify these modules together with the “Estimate and Write” module within the Batch Editor and to set dependencies.

Module “Run DARTEL (create Templates)”

- Images → select two times “new: Images”
  - Images: select the “rp1*-affine.nii” files or create a dependency.
  - Images: select the “rp2*-affine.nii” files or create a dependency.
- all other options: use defaults or modify

The thus created customized DARTEL Templates are now used in the vbm8 Toolbox:

Module “Write already estimated segmentations”

Parameters:
  - Volumes <-X → Select the original T1 images like in the first module “Estimate and Write”.
- Extended Options → “High-dimensional:DARTEL” (default) → Select DARTEL Template
  - if you use dependencies in the Batch Editor create a dependency on the first Template in the batch editor. Templates 2-6 will be used automatically.
  - If you have already created your DARTEL Templates, chose the first Template (named “Template_1” per default). Attention: If you want to rename your template, you may either add a prefix to the default name, or make sure that the template number is embedded in the name between two underscores (e.g. “abc_1_xyz”).
  - For all other options use the same settings as in the first module, or modify.

- Writing Options → select the output files just like in any standard VBM analysis:
  - For GM, WM, and CSF image volumes see page 14: “Additional Information on native, normalized and modulated normalized volumes”.
  - A bias corrected image volume, in which MRI inhomogeneities and noise are removed, can be written in normalized or native space.
  - A partial volume effect (PVE) label image volume can also be written in normalized or native space or as a DARTEL export file.
  - The Jacobian determinant for each voxel can be written in normalized space.
  - Finally, deformation fields can be written. This option is useful to re-apply normalization parameters to other images or particular regions of interest.

- File → Save Batch

- File → Run Batch

**How to proceed:**

All steps described above are just an adaption of the VBM8 Toolbox module “Estimate and Write”. A subsequent smoothing is necessary before statistics can be calculated. As always it is a good idea to save the applied modules and to perform quality control. Here, the modules “Display one slice for all images” and “Check sample homogeneity using covariance” from the VBM8 Toolbox will be helpful.
Additional information on native, normalized and modulated volumes

When preprocessing the images (see “First Module: Estimate and write”, on pages 5-6), the decision about the normalization parameters will determine the interpretation of the analysis outcomes:

“Native space” produces tissue class images in spatial correspondence to the original data. Although this could be useful for estimating global tissue volumes (e.g., GM+WM+CSF=TBV) it is not suitable to conduct VBM analyses due to the missing voxel-wise correspondence across brains. Of note, if one is interested in these global tissue volumes in native space (“raw values”), it won’t be necessary to actually output the tissue class images in native space. The “Estimate and write”-function automatically generates a text file for each subject (*_seg8.txt), which contains the raw values for GM, WM, and CSF. The subject-specific values can be combined (i.e., integrated into a single text file) by using the function “Calculate raw volumes for GM/WM/CSF”:

“Normalized” produces tissue class images in spatial correspondence to the template. This is useful for VBM analyses (e.g., “concentration” of gray matter; Good et al. 2001; Neuroimage).

“Modulated normalized” gives two different options:

- **Affine+non-linear** produces tissue class images in alignment with the template, but multiplies (“modulates”) the voxel values by the Jacobian determinant (i.e., linear and non-linear components) derived from the spatial normalization. This is useful for VBM analyses and allows comparing the absolute amount of tissue (e.g., “volume” of gray matter; Good et al. 2001; Neuroimage).
- **Non-linear only** produces tissue class images in alignment with the template, but multiplies the voxel values by the non-linear components only. This is useful for VBM analyses and allows comparing the absolute amount of tissue corrected for individual brain sizes. Of note, this option is similar to using “Affine+non-linear” (see above) in combination with “global normalization” (when later building the statistical model using the traditional PET designs). That is, when building the statistics, one would specify “Global normalization” → “Overall grand mean scaling – No” → “Normalization – Proportional”. It is also similar to using “Affine+non-linear” (see above) and including the numeric brain volume (as given in the *_seg8.txt file for each subject) as covariate (when later building the statistical model). Although all 3 approaches allow comparing tissue volumes while correcting for individual brain size, it is recommended to use the option “non-linear only” as it applies the correction directly to the data, rather than to the statistical model.

For further explanation see also: http://dbm.neuro.uni-jena.de/vbm/segmentation/modulation
### Naming convention of output files

<table>
<thead>
<tr>
<th><strong>Segmented images:</strong></th>
<th><strong>Bias corrected images:</strong></th>
<th><strong>Estimated raw volumes:</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>m[0]w[r]p[0123]*</td>
<td><strong>wm[r]</strong></td>
<td><strong>pxxx_seg.txt</strong></td>
</tr>
<tr>
<td>m</td>
<td>m - bias corrected</td>
<td></td>
</tr>
<tr>
<td></td>
<td>w - warped</td>
<td></td>
</tr>
<tr>
<td></td>
<td>r - dartel warped</td>
<td></td>
</tr>
<tr>
<td></td>
<td>p - segmented</td>
<td></td>
</tr>
<tr>
<td>0</td>
<td>1 - GM</td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>2 - WM</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>3 - CSF</td>
<td></td>
</tr>
<tr>
<td>_affine</td>
<td>_affine - affine registered only</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

For longitudinal data (default settings):

<table>
<thead>
<tr>
<th><strong>Segmented images:</strong></th>
<th><strong>Bias corrected images:</strong></th>
<th><strong>Mean images (useful for overlaying results):</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>wp[12]mr*</td>
<td><strong>mr</strong></td>
<td><strong>wmrmean</strong></td>
</tr>
<tr>
<td>w</td>
<td>m - bias corrected</td>
<td>w - warped</td>
</tr>
<tr>
<td>p</td>
<td>r - realigned</td>
<td>m - bias corrected</td>
</tr>
<tr>
<td>1</td>
<td></td>
<td>r - realigned</td>
</tr>
<tr>
<td>2</td>
<td></td>
<td>mean - mean</td>
</tr>
<tr>
<td>m</td>
<td></td>
<td><strong>Estimated raw volumes (mean):</strong></td>
</tr>
<tr>
<td>r</td>
<td></td>
<td>pmeanxxx_seg.txt</td>
</tr>
</tbody>
</table>
**Technical information**

This toolbox is an extension of the “New Segment Toolbox” in SPM8, but uses a completely different segmentation approach.³

1. The segmentation approach is based on an adaptive **Maximum A Posterior (MAP) technique** without the need for *a priori* information about tissue probabilities. That is, the Tissue Probability Maps are not used constantly in the sense of the classical unified segmentation approach, but just for spatial normalization³. The following MAP estimation is adaptive in the sense that local variations of the parameters (i.e., means and variance) are modelled as slowly varying spatial functions (Rajapakse et al. 1997). This not only accounts for intensity inhomogeneities but also for other local variations of intensity.

2. Additionally, the segmentation approach uses a **Partial Volume Estimation** (PVE) with a simplified mixed model of at most two tissue types (Tohka et al. 2004). We start with an initial segmentation into three pure classes: gray matter (GM), white matter (WM), and cerebrospinal fluid (CSF) based on the above described MAP estimation. The initial segmentation is followed by a PVE of two additional mixed classes: GM-WM and GM-CSF. This results in an estimation of the amount (or fraction) of each pure tissue type present in every voxel (as single voxels – given by their size – probably contain more than one tissue type) and thus provides a more accurate segmentation.

3. Furthermore, we apply **two denoising methods**. The first method is a spatially adaptive non-local means (SANLM) denoising filter (Manjon et al. 2010). This filter will remove noise while preserving edges and is implemented as preprocessing step. The second method is a classical Markov Random Field (MRF) approach, which incorporates spatial prior information of adjacent voxels into the segmentation estimation (Rajapakse et al. 1997).

4. Another important extension to the SPM8 segmentation is the **integration of the Dartel normalisation** (Ashburner 2007) into the toolbox. If high-dimensional spatial normalisation is chosen, an already existing Dartel template in MNI space will be used. This template was derived from 550 healthy control subjects of the IXI-database (http://www.brain-development.org) and is provided in MNI space⁴ for six different iteration steps of Dartel normalisation. Thus, for the majority of studies the creation of sample-specific Dartel templates is not necessary anymore⁵.

---

³ The classic SPM8 segmentation is still used in addition, but only to initially remove non-brain tissue from the image.

⁴ Thus, no additional MNI normalization is necessary.

⁵ For studies investigating data of children I still recommend creating a customized Dartel template. Of note, for this option a representative sample with a sufficient number of subjects is required (n>50-100). Alternatively, if a sufficient sample size cannot be achieved, the low-dimensional SPM8 normalization approach combined with customized Tissue Probability Maps (e.g. from the TOM8 toolbox) can be selected.
References


2010/04/04

Florian Kurth fkurth@loni.ucla.edu
Eileen Luders eileen@loni.ucla.edu
Christian Gaser christian.gaser@uni-jena.de